Kompatibilität PHP 7

Alle sonstigen Fragen und Antworten (z. B. zu Modulen oder der allgemeinen technischen Realisierung)

Kompatibilität PHP 7

Beitragvon patcash » 27. Apr 2016, 19:19

Hallo,

ist schon absehbar, wann eine zu PHP 7 kompatible Version von Merconis erscheinen wird ?
Derzeit habe ich mit PHP 7 das Problem, daß nach Klick auf "Kostenpflichtig bestellen" nur eine weiße Seite angezeigt wird statt einer Bestellbestätigung.

Die Logdatei von Contao zeigt mir folgenden Eintrag :
PHP Fatal error: Cannot use 'String' as class name as it is reserved in .../system/modules/core/library/Contao/String.php on line 28

Gibt es für diesen (auch von anderen Anwendungen bekannten) Fehler evtl. ein Workaround (umbenennen von "String" in einer bestimmten Datei) ?

Danke und viele Grüße
Patrick
patcash
 
Beiträge: 3
Registriert: 17. Jan 2016, 21:07

Re: Kompatibilität PHP 7

Beitragvon supportteam » 28. Apr 2016, 13:55

Ich habe eben mit unseren Entwicklern gesprochen: Anfang kommender Woche ist eine Prüfung mit PHP7 eingeplant. Sollte es sich herausstellen, dass der Fix einfach zu bewerkstelligen ist, wird dieser kurzfristig (allerspätestens mit dem kommenden Update) veröffentlicht. Ich informiere Sie über das Ergebnis der Prüfung kommende Woche an dieser Stelle.
Ihr MERCONIS-Supportteam
Your MERCONIS Support Team
Benutzeravatar
supportteam
 
Beiträge: 245
Registriert: 28. Aug 2013, 16:58

Re: Kompatibilität PHP 7

Beitragvon dtm » 5. Jul 2016, 14:37

Gibt es hierzu inzwischen einen neuen Sachstand?
Benutzeravatar
dtm
 
Beiträge: 22
Registriert: 5. Jul 2016, 14:22

Re: Kompatibilität PHP 7

Beitragvon supportteam » 5. Jul 2016, 15:06

Hallo,

wir haben die Kompatibilität mit PHP7 bereits im Zuge der laufenden Arbeiten für das kommende Minor-Release fertiggestellt. Der Veröffentlichungstermin der Minor steht noch nicht exakt fest, da wir aktuell noch Features hinzufügen.
Ihr MERCONIS-Supportteam
Your MERCONIS Support Team
Benutzeravatar
supportteam
 
Beiträge: 245
Registriert: 28. Aug 2013, 16:58

Re: Kompatibilität PHP 7

Beitragvon dtm » 5. Jul 2016, 15:10

Super.

Gibt es denn schon so ungefähre Vorstellungen?

1 Monat, 3 Monate, 6 Monate?
Benutzeravatar
dtm
 
Beiträge: 22
Registriert: 5. Jul 2016, 14:22

Re: Kompatibilität PHP 7

Beitragvon supportteam » 5. Jul 2016, 16:02

Ich habe eben mit einem Kollegen aus der Entwicklung gesprochen, der derzeit fest davon ausgeht, dass die nächste Minor dieses Quartal kommt. Das kann natürlich auch plötzlich recht schnell gehen, doch möchten wir hier nicht voreilig evtl. falsche Termine nennen. Sobald der Veröffentlichungs-Termin feststeht, melden wir das wie gewohnt direkt im Newsbereich unter http://www.merconis.com.
Ihr MERCONIS-Supportteam
Your MERCONIS Support Team
Benutzeravatar
supportteam
 
Beiträge: 245
Registriert: 28. Aug 2013, 16:58

Re: Kompatibilität PHP 7

Beitragvon dtm » 5. Jul 2016, 18:19

Hab ich verstanden. Vielen Dank!
Benutzeravatar
dtm
 
Beiträge: 22
Registriert: 5. Jul 2016, 14:22

Re: Kompatibilität PHP 7

Beitragvon dtm » 18. Jul 2016, 09:48

Jetzt wird mir in der Erweiterungsverwaltung eine neue Version angeboten:

Version 2.2.1 Build 14 verfügbar


Ich glaube gelesen zu haben, dass ich die als Vollversion-User besser nicht einspielen sollte. Wäre die dann aber PHP-7-kompatibel?
Benutzeravatar
dtm
 
Beiträge: 22
Registriert: 5. Jul 2016, 14:22

Re: Kompatibilität PHP 7

Beitragvon supportteam2 » 18. Jul 2016, 10:42

Die PHP-7-Kompatibilität kommt mit der nächsten Minor-Version, also voraussichtlich mit der 2.3.0.

Der neue Build 14 der Version 2.2.1 enthält nur eine kleine Optimierung, die für Sie unerheblich ist. Wenn Sie dennoch auf Build 14 aktualisieren wollen, finden Sie die entsprechenden Programm-Files in Ihrem persönlichen Download-Bereich unter merconis.com. Files aus dem Contao-Extension-Repository sollten Sie als Vollversion-User tatsächlich nicht einspielen, da im Contao-ER die Demo-Version vorliegt und Sie durch das Einspielen dann wieder eine Demo-Version hätten.
Ihr MERCONIS-Supportteam
Your MERCONIS Support Team
Benutzeravatar
supportteam2
 
Beiträge: 415
Registriert: 4. Mär 2015, 14:05

Re: Kompatibilität PHP 7

Beitragvon dtm » 18. Jul 2016, 12:26

Verstehe.

Vielen Dank!
Benutzeravatar
dtm
 
Beiträge: 22
Registriert: 5. Jul 2016, 14:22


Zurück zu Sonstiges / Misc.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste